Trig_count error

Hi, I got a problem when putting pqm4-kyber768 on cw.
The problem is when I put the code one stm32f303 board and try to communicate with simpleserial, the feedback from the trig_count is always 0.
I had check my byte length between the target board and my PC, although I change the location of trigger_high and low, it still get 0. Is there anyway to solve it?

Hard to diagnose without understanding your full setup.
If your firmware raising trigger_high()?
Also, CW needs to be armed and triggered in order to count trigger cycles and update scope.adc.trig_count.

Thanks for replying.
In my PC, I’ve trigger it like below.
And in the firmware, I’ve done it like this
My text is a bytearray(32), so I think it can match up with p

I can’t tell from this. I would start by looking at whether the target ever gets to trigger_high() by using a debugger.

Another issue that you are probably running into is that you’re trying to see how long the capture took before you’re even sure that it started. I’d recommend at least moving the read of this value to after scope.capture() and ideally waiting until the trigger goes back low via scope.adc.state.

I found the problem, it is when I try to capture, I ran the scope.default_setup() so it’s got to the wrong setting, thanks for replying me.