"Trigger not found" after multiple captures: Temperature issue?

Hi everyone :slightly_smiling_face:

We have been working with multiple ChipWhisperer Lite devices recently and we noticed an odd behavoir of one of them after performing several thousand captures in a row.

Some context:

  • We are working with the ChipWhisperer Lite, CW308 UFO Board, and the STM32F3 Cortex-M4 Target (three times the whole setup)
  • We are tracing schemes that have cycle counts in the millions and thus for only one “complete” capture we are required to perform ≈100 partial captures of the same scheme (therefore, high offsets are required). This means we want to perform a large amount of captures in a row.

The problem:

With two of the three ChipWhisperers everything works fine. But one of them occasionally displays “WARNING:ChipWhisperer Scope: Trigger not found in ADC data. No data reported!” directly followed by “ERROR:ChipWhisperer Scope: Received fewer points than expected! 0 vs 24400”.

The error mentioned above does not occur during the first ≈5000 captures (this is varying a lot) but at some point it will start to occur and the frequency of the error increases until almost the majority of captures fails.

What we have tried/learned so far:

  • This error is not caused by any of the other parts involved in the setup: We tried interchanging the UFO board, the target, the cables, USB ports etc. So we think it is in fact related to the ChipWhisperer board itself.
  • When pointing a fan directly onto the “faulty” ChipWhisperer the errors do not occur. This is what made us think we might be dealing with a temperature issue. Since the ChipWhisperers are located inside a server room with an AC, we think the ambient temperature should not be an issue.

Our questions

  • Have you ever had to deal with similar issues?
  • Might this be an indication for a hardware issue of the ChipWhisperer board? (it showed this behavoir right from the beginning)
  • What can we do about this? :slightly_smiling_face:

Thank you for reading my post!

Kind regards


If I understand your setup correctly, you’re capturing a series of traces with varying offsets. Can you try increasing the offset factor in https://github.com/newaetech/chipwhisperer/blob/develop/software/chipwhisperer/capture/scopes/_OpenADCInterface.py#L2589 and seeing if that fixes your issue?

While it might be possible that this is a temperature issue, I don’t think it is. Basically everything to do with the scope capture is handled by the FPGA, which I’m pretty certain doesn’t produce much heat.


Dear Alex,

thank you for your reply. Indeed, your suggestion fixed my issue. :slightly_smiling_face:
I am now trying to figure out what the “lower bound” for the offset factor to work is because a higher offset factor increases the measurement duration.
(Still, I am wondering why this only happens for one of the three ChipWhisperers and why this issue was gone after applying more intense cooling. Maybe I’ll do some more testing on this sometime.)

Thank you for helping me to fix this issue!

Kind regards

Haha yeah, the lower bound thing is just something that I found works pretty well at a variety of sampling frequencies and offsets, but still keeps captures pretty quick.

I’ve got no idea why temperature affects this. Maybe something to do with USB?



how can I change the offset factor please, I am looking in the reference python file and can’t get which line. Can you please help?


It’s here: chipwhisperer/_OpenADCInterface.py at develop · newaetech/chipwhisperer · GitHub