Unexpected start to command

Hey there!, I’m trying to connect to a target using Simpleserial but i’m facin gthis kinda of errors and I don’t how to fix them

I’m trying to run “Connecting the hardware”.
I’ve tried to run
"import chipwhisperer as cw
scope = cw.scope()
target = cw.target(scope, cw.targets.SimpleSerial)
scope.default_setup( "
to do the upgrade to the firmware but it took forever run that.
help please.

In cell [5], all the cw.program() calls are commented out; you need to uncomment the one which corresponds to your target, and point it to the firmware that you compiled in the previous step.

As you make your way through the notebooks, you’ll see that most require to figure things out, edit code, or fill in the blanks; the instructions in the notebook will tell you what you need to do (in this case, it says “Whatever your case, upload the firmware we built earlier to the target device.”).

1 Like

Hi, thanks for replying,
I’m sorry, I may have confused this comment with another about an IDE that uses ‘/’; moreover, I’ve uploaded my firmware using the Segger IDE, and when I run it, it shows warnings saying that the _writing and _read…etc; commands always fail.

I’m afraid I can’t use these commands in the other cells.


Looks like you’re using an Arm compiler from Xilinx, which is not the one we recommend in our installation instructions. This firmware should indeed compile cleanly.

1 Like

I’m sorry but i’ve followed the instructions, Like where I should exactly change the directory so ut can recognize the command:
I’ve already changed Makefile.Inc to include these two files:

Please help I’m still sticking in this tutorial.

Looks like you have multiple Arm compilers installed then; the Xilinx one is probably taking precedence because it shows up earlier in your $PATH.

I would either take out /opt/Vitis/ from your $PATH or move it to the end, so that the version installed via apt-get (which on my system lives in /usr/bin/) is used instead. Then, abandon any changes made to our build system.

If compilation is still not clean, can you copy/paste the full make output here.

1 Like

So; I’ve changed the /.bashrc to:

then which arm-none-eabi-gcc would print:

This is my echo #PATH:

I still have these errors,

should I remove everything and rebuild the the Chipwhisperer directory ?

I’m assuming compilation is now clean?

Since you’re using a Segger to program the target, can you (a) make sure the target is running and not halted, and (b) if you pause the target, where is it executing?

1 Like

So when I ran it, it compiled but with a warning that some instructions would fail.

As for the Segger, I was able to build and successfully download the file

I’ve got the firmware built with no warnings this time, but I had no luck in getting an acknowledgment and encountered an unexpected start to the command.