Updating CW Firmware with VirtualBox

I was told my ChipWhisperer-Lite needed a firmware update, so I tried following the instructions here: https://chipwhisperer.readthedocs.io/en/latest/api.html#firmware-update. Getting it in bootloader mode seemed to work fine, but now I can’t figure out how to reprogram it.

When running “programmer.program(’/Users/jse/dev/tty.usbmodem14401’, hardware_type=‘cwlite’)” I get the error:

SerialException: [Errno 2] could not open port /Users/jse/dev/tty.usbmodem14401: [Errno 2] No such file or directory: ‘/Users/jse/dev/tty.usbmodem14401’

I am running this from a VirtualBox version of the Chipwhisperer package. Can I not access my port’s location because of this? How can go about getting my ChipWhisperer up and running again?

Thank you,

I have the same problem as you.I am also confused about this.

Maybe you can try it on another desktop computer. I just solved it on another desktop computer.

VirtualBox only captures specific USB devices, so it may not be passing the SAM3U bootloader through. Start the VM, go up to the Devices bar at the top of the VM, select USB, then select Atmel Corp. at91sam SAMBA bootloader. If that doesn’t work, try https://rtfm.newae.com/Capture/ChipWhisperer-Lite/#linux-usbserial-module-workaround. Let me know if either of those work for you.


Thank you for the response. I actually ended up solving it by installing everything directly on my computer in a virtual environment instead though. Accessing the port’s path was no trouble after doing that, and as a bonus I don’t need VirtualBox anymore :slight_smile: