Windows Permission denied while triying to execute


im working with Chipwhisperer on Windows with msys2 and WSL enabled.
I installed everything described here: Windows Installation — ChipWhisperer 5.7.0 documentation

I get the following error:

Also i cant safe my Jupiter notebooks caused in Permission Error, i tried the following on the msys2 Shell:
LAPTOP-LUCA+luca_@Laptop-Luca MINGW64 /home/portable/chipwhisperer/hardware/victims/firmware
$ chmod 0777 simpleserial-base
chmod: changing permissions of ‘simpleserial-base’: Permission denied

Im running out of ideas, something i dont get?


You tried calling with %%bash instead %%sh ?
I have it installed on two different pc with windows and wsl and one works with bash and the other only works with sh, don’t know why, but maybe it works for you too…

Yes, i alredy tried to user %%bash - with the same result.
I managed to get write permissions, to problem wich followed up is, that the first notbook find the compiler, the second one doesnt.

I switch tu use WSL2 on Windows and routet the USB-Devices throw Ubuntu.
With Ubuntu everything works fine. Sadly Windows is not the best plattform for embedded development…
At least I now save the 20 GB of VS build tools.

Thanks for the reply!